Picture of Nicky NG
Text editor
by Nicky NG - Thursday, 23 May 2013, 12:46 AM

When I posting a forum message, the text editor blocked by the menu, is it because I am using Chrome?  Anyone has idea to solve this?  Thanks.


Re: Text editor
by Mary Cooch - Thursday, 23 May 2013, 1:41 AM

Me too on Chromium - I will go and try some other browsers to see if they are affected too. In the meantime it's a bit like typing blidnfold - you don't know what you are typing! (I could always look at the keys I suppose)

Me at Land's End with iMoot T-Shirt
Re: Text editor
by Gareth J Barnard - Thursday, 23 May 2013, 1:59 AM

Hi all,

I have the same issue here: https://2013.imoot.org/mod/forum/discuss.php?d=591 - happens in other browsers too.

A work around is to change your editor in your profile. Please see...



Picture of Paula Clough
Re: Text editor
by Paula Clough - Thursday, 23 May 2013, 2:38 AM
Thanks, Gareth. That worked!
Paula cool
Picture of Derek Chirnside
Re: Text editor
by Derek Chirnside - Thursday, 23 May 2013, 4:28 AM

So really we are Julian's theme beta tester team.


Good to have you here Gareth, and Julian, a Great theme.

I remember a quote from somewhere, release early and release often.


PS, re the editor in this particular forum.  I'm finding it OK IF the post above is big enough to push it down below the block on the right.

Picture of Derek Chirnside
Re: Text editor
by Derek Chirnside - Thursday, 23 May 2013, 4:36 AM

Julian: alternative forum ckluge fix suggestion for editor to Gareth's.

Reduce the blocks in the left column to one.  A small one.

Editor then spills over a little and we can still type with visibility.


Photo of Becky Barrington
Re: Text editor
by Rebecca Barrington - Thursday, 23 May 2013, 4:44 AM

My workaround is to make my browser window smaller so that the blocks automatically move (due to the bootstrap theme) and then I get to see all the editing window.

I always steer clear of themes with both blocks columns on the right hand side - I don't like it sad  These blocks on this theme are quite wide!

Picture of Randy Thornton
Re: Text editor
by Randy Thornton - Thursday, 23 May 2013, 7:46 AM


Completely agree about the use of right handed themes. The problem is especially acute with double columns. Too many Moodle features need liebesraum to the right hand side.

My workaround is to full-screen the edit box, since the trick of making the browser window smaller did not work for me. (I've tried it in 3 browsers. Should test this in my iPad.)

Turning on docking would provide a better work around: after all, that is what it's for, getting blocks out of the way when you don't want them smile




Andrew Chambers
Re: Text editor
by Andrew Chambers - Thursday, 23 May 2013, 8:09 AM

The iPad and Moodle 2.5 through a browser with this particular editor is problematic. It gives io errors, locks up, runs slow etc. iPads dont support Flash or Java. And this is the root of the problem... We have the same problem on our own 2.3 system with the same editor. I have tested the new Moodle HTML5 app successfully. It might also be worth a try if the server is enabled for it...

Picture of Karrie Anne Vitti
Re: Text editor
by Karrie Anne Vitti - Thursday, 23 May 2013, 6:33 AM

What about if we had the option to dock our blocks... 

Picture of Martin Dougiamas
Re: Text editor
by Martin Dougiamas - Thursday, 23 May 2013, 10:48 AM





A quick way for Julian to fix it would be to remove the wide margins on the page, and another would be to just have one column of blocks (and also remove unnecessary blocks).

Picture of Julian Ridden
Re: Text editor
by Julian Ridden - Thursday, 23 May 2013, 1:59 PM


Your wish is my command. Forums should now be better formatted.


Picture of Randy Thornton
Re: Text editor
by Randy Thornton - Thursday, 23 May 2013, 2:19 PM


Julian - thank you, yes, they are much more nicely formatted smile